» » »

Kia Q&A

Ask Your Question

2003 Kia Sorento Question: Car stalled when pulling away from light.

 

Question

sxyman, 3.5L V6, Simi Valley, CA, May 10, 2013, 17:46
 Rookie

Foot was on the brake, pushed the gas and the car stalled. Restarted the engine, ran fine, pushed on the gas and stalled again. This happened for numerous times. Plenty of gas and had to have the car towed to a shop. We have no problems up to this point. Any suggestions would be appreciated.

Thanks,
John

1 Answer
Flag This
  • Answer #1

    May 10, 2013, 19:56
    Profile_thumbnail
     Enthusiast

    John, were there any signs leading up to this incident? When did the stalling began? How long had the vehicle been running? What was the approximate temperature that day and at the time of the issue you are describing? Were you on an incline? Which motor do you have? How many miles are on the vehicle? What scheduled maint. have you performed or missed? Have you had any repairs or services performed recently? Any odd odors, sounds or vibrations recently? When was the last time you refueled. What type of fuel do you normally buy? How often do you change the oil and filter? Obviously at this point I have more questions than answers, but if you'll take a bit of your time to answer them, I can promise you positive results. Thanks in advance John F.

    Flag This
  • Reply

    sxyman, May 10, 2013, 20:06
     Rookie

    No signs of any problems leading up to it. I take very good care of this car. Car was warmed up from making many stops. It had only been 5 minutes of running when it happend...it was already warmed up with the other trips. It was about 80 degrees around 3pm. I was on a straight road. It's a 2003 Kia Sorrento V6 standard engine. All maintenance has been performed and nothing has been done to the car for the past 6 months. No ordors, no sounds or vibrations. It was refuled that morning with regular gas as recommened by the Kia. Oil and filter changes ever 7,500 miles. I do all my own work as I know cars well from my drag racing days. Any help would be appreciated and no check engine light.

    I found the problem. It was the idle control valve that failed.

    Thanks,
    John

    Reply
    Flag This