car is overheating while idling and moving?is it the Thermostsat or water pump? on 2003 Audi A6 Quattro

First my my reservoir cracked then while idling it had water running all over the place ,,I fixed one of the problems and had a few hoses and clamps replaced but it won't stop running hot . It starts getting hot after only 15 mins while driving then when i pull it over to cool it goes to the normal but then the i have to check the reservoir the coolant goes down and then the pressure is so built up it pushes the coolant back up to the I really need help with this

by in Piedmont, SC on May 07, 2013
2 answers 2 comments
ANSWER by on May 08, 2013
these engines have plastic water pump impellars,most likely the impellar has fallen apart. very common.
COMMENT by on May 11, 2013
It sounds like a possible probable thing ,but there is the thermostat that could be stuck ,and won't open because its either clogged or not opening like its supposed to. What do you think about that ??.... Thank you for your response !!
ANSWER by on May 08, 2013
Sounds like you have an air pocket in the cooling system. Let it run with the cap off and fill coolant. Make sure the cooling fans are working.
COMMENT by on May 11, 2013
I have checked the fans and have found them to be working . I honestly believe its the thermostat not opening and closing like its supposed to ..what do you think??... I don't believe or going it to be the water pump , because they leak and make a loud noise ,, what do you think ?? Thank you for your response !!!. X