Oldsmobile Q&A

Ask Your Question

1995 Oldsmobile Cutlass Supreme Question: Car has a loss of engine power, fuel mileage and is running hot

 

Question

scorpiowoman1025, 3.1L V6, Rancho Cordova, CA, January 19, 2011, 10:02
 Rookie

My car has a loss of power, especially on inclines, gas mileage is greatly reduced and now it is running super hot but not overheating. It had a service engine soon light for about 30 seconds but that is it. Not sure if that is the same as a check engine light as I do not have the book and bought this car used. Radiator was replaced the day we bought the car.

1 Answer
Flag This
  • Answer #1

    mastertech6371 January 19, 2011, 10:22
    Profile_thumbnail
     Master

    from your description, it sounds like a cat converter clogged causing these issues. a shop can verify it for you with a scan tool and a snap throttle test.

    Roy

    Flag This
  • Reply

    scorpiowoman1025, January 24, 2011, 07:36
     Rookie

    I took it to a shop paid for a diagnostic and was told it was the fuel pump, very little fuel pressure. We replaced it Friday and it still has the problem. Still no fuel pressure with new pump and and new filter. All fluids are fine, we have done the air filter, fuel filter, wires, spark plugs, etc and I am frustrated and worried about becoming stranded, a little hard to start now in the morning too. Any ideas?? Now I am being told that the fuel pump they put in is bad, hope it doesn't turn out to be catalytic converter

    Reply
    Flag This