Car cranks.Has fuel.Has spark and no start. on 1999 Mazda 626

Car started acting up about a year ago when I started having to replace the spark plugs just to get the car to accelerate properly. has had the timing belt replaced, coil pack, Crank position sensor and cam position sensor..and I can't pull any codes because the car can't even start! any help would be greatly appreciated

by in London, OH on December 08, 2012
1 answer
ANSWER by on December 11, 2012
IF you have spark(to plugs) AND you have fuel(to cyl.-injectors working) then re-checking timing (For both valve and ignition) might be a place to start.
1 person likes thisFlag inappropiateReply
Related Items:
My car cranks up but doesn't start. I have confirmed perfect timing. Redid that twice. Confirmed spark. New coil and wires. Confirmed gas. When I pulled the tube between the fuel rails gas squirted...
UPDATE: The shop said it's the distributor, and they want to charge me approx $850 to replace it. (on a 16 year old car!) Does that sound like a reasonable cause for the problem? And does that sou...
So I'm having no spark. Changed coil pack and spark plug wires as well as crank sensor. I am getting fuel and compression as well as a fully charges battery. Also am getting 12 volts to the coil po...
i just replaced the timing belt on the car everything lined up perfectly, also replaced fuel pump that was bad. i tried turning it over cranks but will not start put starter fluid in throttle body ...
was driving then the car just quit. changed the distributor with no results. when you push the gas to the floor it sounds like it tries to start. seems to be getting gas with the exception when ...