» » »

Mercedes-Benz Q&A

Ask Your Question

2005 Mercedes-Benz C240 Question: Can worsening crankshaft sensor affect air mass sensor?

 

Question

Bcowake, Green Bay, WI, January 25, 2013, 10:33
 Rookie

For 6 months has occasionally threatened to stall, with onset of colder weather would not start readily, holding accelerator halfway down seemed to help. Check engine light came on once 4 months ago and logged code that air mass sensor failed. Replaced that & checked air filter. With onset of cold weather start problem ensued with regularity. Cold weather start problem first occurred at about 30K, dealership fixed under warranty. Have since taken it to independent import repair shop with excellent service history of 30+ years in NE Wisconsin. Bought extended 2-year warranty with car so forced to go to MB dealer with limited diagnostic skills. Was told that replacing regular octane with premium solved the problem......after they had it for 3 weeks. After reading on RepairPal about crankshaft sensor failure on C240s, asked if they had checked that and was pretty much dismissed.

1 Answer
Flag This
  • Answer #1

    Greg's Orange Auto (12184 Answers) , Orange, CA - (714) 361-9386
    globalhelper January 25, 2013, 12:34
     Master

    scan codes and post so we can adv

    Flag This
  • Reply

    Bcowake, January 26, 2013, 05:30
     Rookie

    Codes unavailable. Dealership replaced 2 month old Bosch oem air mass sensor with "Mercedes" Bosch air mass sensor, replaced gas....says car starts now.

    Flag This
  • Reply

    mlee1951, April 12, 2013, 21:37
     Rookie

    I have encountered a check engine light on and it pointed to the MAF. My mechanic clean the MAF and the car ran fine for over 4 months. Then, when the cold winter kicked in, my 2004 C240 with 45K miles, started to have problems starting up in the morning. I took the car in and had the car serviced (full tuneup with all the filters, fluids, and spark plugs replaced). My mechanic also replaced the Crank and Cam Position Sensors. All this service, the car is still having a problem. The car is being checked out to see if there is a problem with the fuel pump (pressure checking to make sure it holds at 40 psi). If the problem is not with the fuel pump, I guess I will have him recheck the MAF.

    Additional notes:
    The hard part of the coldstart (first startup), the C240 will crank and crank without firing up. After quite of few attemps of trying to start the car, it will start to sputter, but still won't fire up. Eventually, after numerous attemps, it sputters and fires up.

    Once I managed to start the car, it run really fine on the road and freeway. I can shutoff the car and go out for dinner and the car will immediately restart without any problem.

    The car was hooked up to a diagnostic machine and it couldn't find anything.

    Reply
    Flag This