26
questions

No brake lights.. But all lights are working

service engine soon light has been on for a week

anti theft light is on. help

I have spark and have fuel but am still just cranking and not starting. I shot some starting fluid in and still a no start. I replaced the fuel filter and the fuel pump was done a year ago. I can hear the pump kick on and there is pressure at the rail. I don't think it's a Vats issue bucause the security light is not on. I'm lost Please help

I have replaced battery and alternator and plugs/wires in the last year

it happens 3 or 4 times then stops for a week or two and starts again


My problem was a empty resevoir of Power Steering fluid

It is having major electrical problems. The entire dash shuts off going down the road. this is not only problem. I also need to know why my brakes do not work. I replaced all brake lines. they blew out. I bled all calipers several times. still only have one brake. should i change out master cylinder.

Please DO NOT tell me it's a groundng issue, unless you have specific areas for me to check. I have the wiring diagrams, and have even spliced into the ground wires from the display panel and the passenger side ecu (and ran directly to ground), I've replaced the alternator, reworked the grounding points on both sides of the nose of the car, replaced fuses (and the breakers... yes, breakers), and have wire brushed the power bar in the front power fuse and relay center, but still have the same issue. The display only works on start up, AFTER it has been parked on a slight up hill, and slight tilt to the right. To me, this makes it seem as though it's a power supply issue. It will then go out again once I start driving, or not.

I have to stomp on the accellerator very hard to get it to release. I thought a broken engine mount might be the problem but isn't.

I tried to push brake and release shift but it will nit release from park.

how to tell if your fuel pump is bad.and where is the fuel pump.

Had a new transmission installed in my Cadillac. When I got it back the cruise control no longer worked. They said it needs a new switch and the cost of the part was $190.00, plus the cost of installation. I told them it worked before they started on the transmission - they said it was probably ready to go out and they were not responsible for it.

ok ty for being here, we desided to replace the front struts ourselves and the sway bar link, k. the tow-in is now fairly bad. The car is driven 120 miles each day (Mon,-Fri.) is there a adjustment we can make that will help the car make it through the next two weeks till a wheel alignment can be done by a shop? We have spent all the money on the parts and have to wait till next check. Thank you for answering ASAP, as new tires are a long ways out in this economy.

battery good- current goes to maxifuses to alt but no lights, doors, radio, dash board ... nothing. Most cars have a fuse from battery to the rest of car. where is this fuse here.