1997 Cadillac Seville SLS Questions

Answered 1997 Cadillac Seville SLS Questions

Ask a Question
View:RecentAnsweredUnanswered
Car has been over heating...replaced water pump and hoses, also did a flush. Everything was fine for a month or so, then had metal hoses replace...car ran fine again after a long distance trip. Now, car is back to ove...
4.6 liter northstar engîne
I have had the battery checked and fully charged and it clicks when trying to start
After checking all hoses and checked for possible leaks, then changed out the thermostat and replaced water pump, the temp gauge will still move towards red zone. What or where should I look next?
Very little rust on whole car except where rear subframe mounts attach. Car is in good shape, but don't know if it's worth the fix based on age of the car.
Cylinder came with 2 keys. These keys turn the ignition. I had a locksmith make me a key with the raise chip and this key will not turn the ignition.
The following codes have been read from the computer...P0122, P0741, P0174 and P0300 while driving, the engine acts like it is misfiring, with a little hesitation when accelerating. A tune-up was done last year with p...
Sometimes l will turn the ignition key and l get nothing at all. I move the gear shifter into park hard and it starts. Service steering system light comes on. I can be driving at 30 mph and the car will dies out the...
I have been having problem after problem with this car lately it only has 86,000 miles on it & pretty much has been babied for lack of another word. Well my biggest problem lately is it started giving problems startin...
I have had problem after problem with this car, 2 major issues will not start unless starting fluid is sprayed & 2(new battery 1mo ago tested & is good battery) when idling(sitting at light, etc..) if I turn heat on t...
c1255 says internal malfunction. where is the traction control switch or sensor
When the gas gauge reaches a quarter of a tank, it travels in the opposite direction. What can the issue be?
everytime i pull the hose apart the coolant is coming out but when i starts it, it won't go through.