1999 Buick Century Questions

Answered 1999 Buick Century Questions

Ask a Question
View:RecentAnsweredUnanswered
The leaking has stopped, but the overheating hasn't. I was told it was the water pump then told the water pump won't start leaking then stop. What are possible issues? However, when I look in the container, the antifr...
Just typical price ... not expecting and exact quote. I am just researching and weighing options.
Last time it worked for 2 days and no more. Also the fuel gauge doesn't read the reel fuel level. sometimes I fill up the tank but it read empty or sometimes the opposite, I may get a little oil but it read full. What...
I changed the fluid, filter, and oil. Checked the filter to see if fell, it didn't, but it still wont engage. there is one weird thing. I no longer have to press the brake pedal to move the shifter. Is there a neutral...
Lite comes on after driving 1/4 mile. Now I'm afraid to drive it. 1) can I drive as is for about 3 miles to mechanic? 2) OR should I just have it towed to mechanic? 3) OR should I have tow truck fill it with a...
Coolant light comes on quite often but the radiator is full. Also the radiator has slime around the neck. I thought i WOULD TRY and do a flush and see it that helps. The car never runs hot.
The remote to enter and lock my car, was stolen.
I have bought new tires 3 times in one year, a shade tree mechanic said it was due to the rack n pinion. Not sure of the spelling but thats what he said.
Just bought this car 3 weeks ago. Last week service engine soon light illuminated and stayed on. Advance Auto tested and code was P0550. Gas cap is good, so they suggested Fuel Injector Cleaner and reset light. 2 days...
and I just recently changed the thermostat in it. The temperature gauge is right where it should be so it is not overheating. When I took the radiator cap off it was full of gunk. I am wondering if I should replace t...
had repair tyrod inner-left & outer-right also front struts replaced & front end alignment-steering was locking up whengot back-took back bearing on top of struts replced-helped right-but left very tight when parking...
There is no in between, either full or empty, Speedomter does not work either.
no lic. plate or back up lights. have already replaced fuse and bulbs. could this be the ground wire and if so . where is it located