» » »

Mercury Q&A

Ask Your Question

1999 Mercury Villager Question: bought it used a few months ago the water pump had gone out , we replaced it

 

Question

glass1, 3.3L V6, Mattoon, IL, May 13, 2014, 10:36
 Rookie

seemed to fun fine for a few days then it started cutting out very bad when the engine got warm and would even die. Replaced the distributor and plugs and wires again ran fine for awhile. Now some times it wont start engine turns over but will not start, and other times starts cutting out and dies after short distances took it back to where we bought the dist. they changed the cap said it had a crack in it again did good for a couple of days but is doing it again any ideas

2 Answers
Flag This
  • Answer #1

    May 13, 2014, 13:27
     Journeyman

    When you say the distributor and plugs and wires were replaced, I guess you meant that the distributor cap, rotor, sparkplugs, and spark plug wires had been changed. A worn distributor bushing would cause the new distributor cap to break that quickly. Have a qualified mechanic shop check for a worn distributor shaft bushing and replace if necessary.

    Reply
    Flag This
  • Answer #2

    May 13, 2014, 14:36
    Profile_thumbnail
     Master

    Agree with #1...This van has a Nissan engine and those distributors give a BUNCH of trouble!!!! That's the distributor assembly, btw.... Replace the distributor assembly with a 'new' unit.....if needed, ...the reman's aint hitting on much! ...No use trying to repair old dist!!

    Reply
    Flag This