» » »

Chevrolet Q&A

Ask Your Question

1992 Chevrolet S10 Blazer Question: blazer running very rough

 

Question

beeans, Marblehead, MA, July 21, 2009, 15:38
 Rookie

My Blazer has been sitting for about 10 months and has been started a few times within those months.. It now runs very rough.. when first started, it idles very hard up and down, up and down. Then when I go to drive it, it acts as though the gas is being cut off from it and jerks very violently.. I'm not sure if anyone else has had the same issues. It is a 4 door 5 speed 4x2. It may be the egr valve, I'm not sure.. the fuel filter was change 2 years ago. please help.

3 Answers
Flag This
  • Answer #1

    Jhama009 July 27, 2009, 07:42
     Rookie

    Check your map sensor.. It runs to your breather....
    Unplug it or it's unplugged. That's one of the possible idle ups and downs.

    Reply
    Flag This
  • Answer #2

    zsmith93 September 06, 2009, 09:18
     Rookie

    My blazer was doing the same. I changed the plugs and wires and then used multiple rounds of injector cleaner on it and the rough idle got better. Im going to change the starter, oil/filter, transmition fluid/filter, and hoses to try to get it gone totally.

    Reply
    Flag This
  • Answer #3

    mrmatthew50 November 06, 2013, 14:18
     Rookie

    I COULD TELL YOU A ANSWER THAT WORKED FOR ME AND THAT IS THE SPARK PLUGS FOULED OUT AND I HAD TO BUY NEW ONES THE CHEAP PLUGS ARE AC DELCO AND THEY SUCK WHAT HAPPEND IS THAT ONCE THE MOTOR HAS WARMED UP AND YOU SHUT IT DOWN THE PLUGS FOUL OUT OITS WEIRD BUT THATS WHAT WE3NT ON WITH MINE I PUT ANOTHER SET CHAMPIONS 2'39 EACH AUTO ZONE AND IT RUNS PERFECT YOU COULD TRY IT IF YU WANT

    Reply
    Flag This