» » »

BMW Q&A

Ask Your Question

1991 BMW 525i Question: ar's dash lights and tail lights do not work. All fuse hood rear seat OK.

 

Question

gsum, Findlay, OH, July 22, 2012, 13:41
 Rookie

Two days ago...dash lights and one tail light(left) were fine...Dash message told me tail light out...The right on was. Removed the light shocket on the right side...replaced 10w sliver base bulb
rated for BMW replacement for tail light. As I was replacing the bulb socket back into body port
all went black...Now I have NO tail lights and NO
dash lights. I assume that a short must have been created as I was placing the right bulb socket back into the body cavity that holds the buld and socket. I also assume that the metal contact points at the top of the right bulb socket must have shorted some way??? All I know is I have no
tail or dash lights. All fuses show OK?? Does any one have a resolve for my problem??? I get no warning message on the panel indicator. Again 1991 BMW 525i automatic Any one can hit me direct at
gsummers@woh.rr.com or post back on blog board...
ANY HELP MUCH APPRECIATED!!!!!!

1 Answer
Flag This
  • Answer #1

    ziptie12 July 22, 2012, 19:46
     Master

    Check owners manual for ALL locations of fuses , and check the trunk wiring harness for broken wires

    Flag This
  • Reply

    gsum, July 23, 2012, 07:20
     Rookie

    gsum in follow up to reply to 1991 525i dash and tail lights not working. I have checked all possible fuse locations already...Have checked trunk wiring as well...will do again. Advise which color wire or wires in the harness would I most likely be wanting to RE-CHECK more closely??Any other possible locations to check?
    Has any one else on the blog had this same issue. All other light systems in the car work. Like I posted earlier the dash lights and left tail light worked fine until I changed the right tail light bulb. At bulb replacement the dash and tail lights both do not work. The tail lights went down as soon as I put the new bulb in the right light socket unit and replaced it back into the car body tail light area??

    Flag This
  • Reply

    ziptie12, July 25, 2012, 10:27
     Master

    I DON'T want to sound insulting , but re-check the bulb installation and be sure it's the correct bulb as I'm sure you know already , many can look the same but function differently , especially in systems with lamp-out sensors.

    Flag This
  • Reply

    gsum, July 25, 2012, 11:41
     Rookie

    Not to worry about insulting me...Bulbs...they are sliver base 10w as the bmw manula calls for. Besides...if it were the bulbs why would the dash lights be out as well as the left tail light? The left was fine until I did the right bulb change...Thanks for the follow through. Another issue came up on the same car...Now...I have a heat up issue. Earlier in the month I has a slight heat up once an a while...I did a change of w-pump and thermostat...The car ran great for 3-4 days...Started up yesterday went about a mile and now I get major
    heat up...rolls to almost red in 1 mile or less??? Thinking fan cool relay??Maybe time to burry this old dog.

    If you have any ideas advise...Hit me direct via gsummers@woh.rr.com Thanks gsum

    Flag This
  • Reply

    ziptie12, July 26, 2012, 10:27
     Master

    Sorry about the delay in reply.I was wondering , on your over-heating issue-- with the system closed, from a cold start, does the rad hose feel like the system is building pressure right away? Does it feel like bubbles are coming through it? As for your less important issue at this time , what did you find on your light problem? Popped fuse when socket installed? Curious ...hope someone out there has got you some better answers than me.

    Reply
    Flag This