Mercury Q&A

Ask Your Question

2008 Mercury Mariner Hybrid Question: Anyone having battery or drainage problems? Do the hybrids have an alternator?

 

Question

amarce, Fort Collins, CO, July 01, 2011, 18:58
 Rookie

So I have recently been having a lot of problems with my car. About a year ago my radio/navigation screen wouldnt work every now and again. My car was still running & I was fully able to drive it, but the screen wouldnt work & when I would push the power knob the Mercury symbol would show on the screen with the time & then it would go blank & stay that way. Sometimes it would start workin again while I was driving, other times it wouldnt start working again for days. Shortly after my 1st battery died & that didnt have that problem for about another year. And then it happened again where the screen wouldnt work and then a few weeks later my car wouldnt start because my battery had died. So I got another battery and went on vacation for 2 weeks & when I came back my battery was dead yet again. I didnt leave any lights on or anything. Im thinkin there might be some kind of drainage or maybe its the alternator if there is one. Can anyone help or has anyone else gone through this??
I also got some kind of flap on my electric motor replaced & it cost over $300 to fix. Has anyone had to do this & know whats the purpose of it? I feel like the I really got screwed over by the dealership.
Thanks All!!!!

1 Answer
Flag This
  • Answer #1

    July 01, 2011, 19:09
    Profile_thumbnail
     Master

    there are so mant modules and computers in todays cars that when they stop communicating with each other, it gets kind of tough to diag. you need a good electrical shop to help you here. my guess is a possible bcm for the display.
    as far as the battery, you may have a weak alternator and that needs to be checked as well.

    Roy

    Reply
    Flag This