Car Problem Reports

Mercedes-Benz S500 Airmatic Pump Motors May Fail Due to Sticking Relays

 
Mercedes-Benz S500 Problem
19 Reports
Me Too
Edit

Model Years Affected: 2000, 2001, 2002, 2003, 2004, 2005, 2006

Average Mileage: 127,569 mi (75,000 mi - 285,000 mi)

Verified

The relay which turns the airmatic suspension pump on may fail causing the pump to run continuously. This can result in failure of the pump motor or a dead battery as the pump motor will continue to run after the car is turned off. Also, Worn airmatic pump mount bushings can causes noises in the front axle while driving on bumpy roads or a buzzing noise while the pump is running.

  • Visitor, , 105,000 mi

    Relay failed in continuous connection mode, which burnt the 40A fuse as a consequence. Replaced both. also replaced similar fuse which controls the secondary pump as a precaution.

    Flag This
  •  Rookie

    car was sitting on the bump stops one morning. started and could hear a clicking sound under right hood. it was airmatic relay. did not get it off in time for old pump. burned up pump and then fuse.

    mercedes wanted 1800 for job, including part which i did buy from them for about 400. an indie offered 800 total over phone, then boosted to 1200 when i drove in, so i passed. anyway, did it myself without air tools or the best of tools, and no previous experience on this type system in an hour and a half. very easy and it worked. have actually even replaced an air strut since and need to do another which is also really simple. ordered strut online for only 355 though it is aftermarket it works great.

    Flag This
  • Visitor, , 106,000 mi

    While driving a Red warning light came on saying "Stop - Car Too LOw"

    Flag This
  • Visitor, , 285,000 mi

    same problems, car so low after I turn motor on rising start all ok, driving ok, but after couple hours car parking is agagin red info stop car so low, will be soon see mechanic best m

    Flag This
  •  Enthusiast

    Airmatic workshop lights come on a lot after I changed the struts in the front, sometimes it comes on when I am driving down the highway and then it goes away will have it check when I can afford it. Just replaced struts which bankrupt me for a while.

    Flag This
  • Visitor, , 119,992 mi

    this is the second time. First failure was at ~60,000 miles

    Flag This
  • Visitor, , 75,000 mi

    would not operate about a year ago,so had it repairded.

    Flag This
  • Visitor, , 130,000 mi

    Turned off car and heard clicking noise and pump trying to come on. Unhooked battery. Will see if I can locate relay and replace.

    Flag This
  • Mine is on now visit workshop, I think same problem, it's working fine

    Flag This
  • Visitor, , 108,000 mi

    Rattling noise and pump turning on and off when car door is opened. Car lowers down to the rim on rear of vehicle...unevenly (rt side lowers 1.5 inches more than left side but both are significantly lower than front). Car lowers after sitting just 30-45 minutes. Now pump doesn't come on at all and console displays airmatic - visit workshop message. Found out this morning that it could be the relays on the pump. Probably will change entire pump.

    Flag This
+ See more reports
Ask a Question