air conditioning works but no fan inside same with heater on 1990 Mercedes-Benz 300CE

when heater and air conditioning comes on no fan, sometimes in long trips fans come on but for short times ?

by in Garden Grove, CA on January 06, 2010
4 answers 2 comments
ANSWER by on January 07, 2010
There are three things here to look at the blower motor resistor which is just behind the battery, and the auxiliary fuse holder that supplies power to the motor (25 amp fuse), blower motor is in the engine compartment in the center top (under the cowl panel under the wiper motor). Fuse 11 (an 8 amp fuse ) also provides power to the heater controls/ motor circuit but if it fails the horn also fails. Red wire at the fan motor should make the blower motor operate when power is supplied to it if the blower motor is good, the brown wire at the motor is ground. Usually the blower motor resistor that fails.
ANSWER by on March 12, 2010
Try the blower switch contacts. Remove the switch and clean the 4 relay type contacts. The contacts gets become dirty over the years.
ANSWER by on June 01, 2010
Both answers are wrong. It is the blower motor control regulator. It is located directly under the blower motor. New they are 400+ but you can find used ones for $50. I had the exact same symptoms. not hard to replace.
COMMENT by on October 26, 2010
i do have the same problem with my 300ce where do you think i can find it for $ 50 please could you let me know as soon as possible please contact at [[ ]]
COMMENT by on October 26, 2010
i got the same problem with my please let me know where to get it for that price... at
ANSWER by on November 09, 2010
ohoo, how i found out with accidental circumstances, the blower motor is exposed in the elements (right under the wiper motor,) really its removing the molding for wiper and you can see the black box>> take cover off and remove rust or whatever debis trust me you just saved 900 dollars for alittle time!!!

Related Content