GMC Envoy Problem Report

GMC Envoy Loss of One or More HVAC Blower Motor Speeds

(109 reports)

The HVAC blower motor may stop working at one or more speeds due to a faulty blower motor resistor block. Our technicians recommend to confirm the resistor is at fault by first checking the operation of the switch.

No blower at all, either hot or cold -
Blower fan continues to run when engine is shut off. -
My blower stopped working 1 # at a time and today #5 finally went -
Position 4 on fan control know does not work any longer. Other positions work fine. -
Blower only works on 4/5 ... -
The blower for the back of the vehicle is stuck on and is blowing hot air. It will not turn off and it won't blow cold air. Also, The blower level 5 in the front part stopped working. The air conditioning is not working in the front either. -
Possible blower motor resistor. -
Blower was not working on 3, 4, 5, fixed it now it is not working on 5 at all and 4 sometimes. -
Blower motor does not cut off, sometimes, a/c and defrost. Ran bartery down. -
Heater would not blow properly. It was only at one speed. Had to take it in and replace the blower motor -
Ac only working when the weather temp Is below 80 degrees. Blowing hot air. -
ac fan quit... -
Funny, It 1st started not coming on at all, turn engine off get back in, turn on and it would blow all day as long as engine stayed running. Then certain fan speeds, then it would stay blowing after engine off. -
blower motor don,t come on all the time -
Fan does not work at all at speeds 1 to 4 but works at speed 5 (max speed). -
No blower for hot or cold. -
I haven't got fixed -
Defrost, air and heating doesn't have any air blowing out on any speed or temp. -
Does not work on 2,3, 4 Blower speed -
same problem but my blower only fails on the highest fan speed which is No. 5 -
Related Items:
how to replace ac compressor bearing
blower motor speed selections not working
no ac no heat blower does not work not a fuse
Even when truck is turned off the blower is running at the top speed. I have removed the fuse...
my ac blows for like 30 seconds randomly after i turn the car off..... i dunno if its a feature...