Chevrolet Q&A

Ask Your Question

2004 Chevrolet Trailblazer Question: abs/brake lts on

 

Question

djc1766, 4.2L 6 Cylinder, Hubbardston, MA, March 30, 2009, 10:26
 Rookie

I have my ABS & BRAKE LTS ON. I HAVE REPLACED THE CONSOLE MODULE CLUSTER,THE ODOMETER BASICLLY,1 DAY LATER ABS,BRAKE LTS ON ? How do i repair this,HELP PLEASE ! DJC1766@YAHOO.COM

1 Answer
Flag This
  • Answer #1

    March 30, 2009, 20:46
     Master

    The cluster may need to be programed to your vehicle. Where did you get the cluster that you installed? Did the warning light problems start the first time you drove with the new cluster?

    Flag This
  • Reply

    djc1766, March 31, 2009, 10:10
     Rookie

    Russ,
    Thanks for your help. The lt came on after two days of driving. How can we program this new one w/ my truck ??
    djc
    I bought it from a auto parts place in mass.

    Flag This
  • Reply

    Russ, March 31, 2009, 20:33
     Master

    If it took two days for the ABS light to come on I don't think it is a programing issue. There is a remote possibility it could be so check with you parts supplier and find out if programing is necessary - you cluster may have been preprogramed. With the ABS light on a fault code should be set in the ABS control module. You will need a scan tool to access the module and read the code. The stored fault code should lead to the cause of your ABS light on.

    Flag This
  • Reply

    djc1766, April 04, 2009, 09:58
     Rookie

    I have fixed the problem. Right next to the abs module the wire was probed "in the past" checking for continuity i asume, well the wire was cracked and in powder form. therefore no power to the fuse panel,hense signalling a problem w/ abs. wire pliced and heatsrinked, NO ABS LTS OR BRAKE LTS.. Also no CLUSTER problem..

    THANK SO MUCH FOR YOUR HELP. WHAT A GREAT FORUM THIS IS..

    Flag This
  • Reply

    Russ, April 04, 2009, 21:33
     Master

    Great job!! I am glad to hear you found your problem.

    Reply
    Flag This