abs/brake lts on on 2004 Chevrolet Trailblazer

I have my ABS & BRAKE LTS ON. I HAVE REPLACED THE CONSOLE MODULE CLUSTER,THE ODOMETER BASICLLY,1 DAY LATER ABS,BRAKE LTS ON ? How do i repair this,HELP PLEASE ! DJC1766@YAHOO.COM

by in Hubbardston, MA on March 30, 2009
1 answer 4 comments
ANSWER by on March 30, 2009
The cluster may need to be programed to your vehicle. Where did you get the cluster that you installed? Did the warning light problems start the first time you drove with the new cluster?
COMMENT by on March 31, 2009
Russ, Thanks for your help. The lt came on after two days of driving. How can we program this new one w/ my truck ?? djc I bought it from a auto parts place in mass.
COMMENT by on March 31, 2009
If it took two days for the ABS light to come on I don't think it is a programing issue. There is a remote possibility it could be so check with you parts supplier and find out if programing is necessary - you cluster may have been preprogramed. With the ABS light on a fault code should be set in the ABS control module. You will need a scan tool to access the module and read the code. The stored fault code should lead to the cause of your ABS light on.
COMMENT by on April 04, 2009
I have fixed the problem. Right next to the abs module the wire was probed "in the past" checking for continuity i asume, well the wire was cracked and in powder form. therefore no power to the fuse panel,hense signalling a problem w/ abs. wire pliced and heatsrinked, NO ABS LTS OR BRAKE LTS.. Also no CLUSTER problem.. THANK SO MUCH FOR YOUR HELP. WHAT A GREAT FORUM THIS IS..
COMMENT by on April 04, 2009
Great job!! I am glad to hear you found your problem.
Related Items:
i was told the part i needed was called a throttle position sensor. cant find that part. please help.