» » »

Hummer Q&A

Ask Your Question

2003 Hummer H2 Question: ABS Light

 

Question

jab228, Maryland Heights, MO, July 22, 2009, 12:23
 Rookie

I had the front driver side hub assembly replaced recently and since then my ABS, Brake, and Traction control dash warning light comes on. Prior to this replacement the warning lights never came on. When I first turn the truck on they do not stay on however after driving for 10-15 minutes all the above mentioned lights come on and stay on until I turn the truck off. Does this have something to do with the Hub assembly replacement? If so what can be done?

4 Answers
Flag This
  • Answer #1

    Russ July 22, 2009, 13:32
     Master

    On your 2003 Hummer H2 the front wheel speed senors are mounted on but not part of the hub assembly. The first step is to read the fault codes set in the ABS control module - the fault code should help isolate the location of the problem. If the fault code leads to the front drivers side wheel speed sensor then the fault may be related to the hub replacement. There is no way to tell if the light is related to the hub replacement without properly diagnosing the fault code stored in the ABS module.

    Reply
    Flag This
  • Answer #2

    tlebofsky September 04, 2009, 22:42
     Rookie

    Sounds to me that the wheel speed sensor was not hooked back up or the mechanic broke it when replacing the hub.

    Reply
    Flag This
  • Answer #3

    Visitor, December 16, 2010, 10:45

    Tell me if you figure that out I had the same thing happen to me

    Flag This
  • Reply

    Visitor, January 25, 2011, 15:38

    i have an 06' H2 with exact same problem. It's reading that wheel as going 10MPH faster than the others. Tried changing the sensor and it didn't help. Has anyone figured this out?

    Reply
    Flag This
  • Answer #4

    Visitor, March 07, 2011, 10:49

    I had the instrument cluster replaced on my 2003, and now those same three lights come on after about ten miles of driving. They are telling me that the abs module is bad, but it never did this untill I spent 650.00 to have it replaced. Now the module is 685.00. Could they just not have hooked it up like they guy with the front hub? I had my front hubs replaced and it did not happen then.

    Flag This
  • Reply

    Visitor, May 05, 2011, 15:16

    I am having the same exact problem. I have an '03 H2 and need a new instrument panel due to light bulbs around the speedometer have burnt out. I just put new brakes on and after that I have been having parking brake; ABS; traction control warning lights come on after a short time of driving. They stay on while I am driving and the warning bell for the parking brake sounds off and on. has anyone gotten to the bottom of this problem? I took it to my mechanic and he suggested I start with replacing the instrument panel since I need to do that anyway and go from there.

    Reply
    Flag This