» » »

GMC Q&A

Ask Your Question

1999 GMC Jimmy Question: ABS chatter

 

Question

Visitor, Taunton, MA, December 01, 2010, 19:47

abs chatter when stopping, no idiot lights, can hear abs module running, new front wheel bearings both sides from being noisy, abs chatter there before this work. ABS module?

3 Answers
Flag This
  • Answer #1

    December 01, 2010, 19:55
    Profile_thumbnail
     Master

    usually a clearance issue with the sensors. check the front sensor mounts. make sure they are clean and sitting true.

    Roy

    Flag This
  • Reply

    Visitor, December 01, 2010, 21:20

    The hub bearings and the wheel speed sensors are a sealed unit that bolt on. No sensor ring on this. No codes come up, I unplugged sensors to stop chatter, then I get dash light and a code that they are unplugged. The sensors are matched to the hub bearing

    Reply
    Flag This
  • Answer #2

    December 01, 2010, 20:55
     Master

    ck computer codes so you can find problem clean all speed sensor on all 4 wheels could be bad abs module unplug and drive abs lite will burn it shood make brake like older truck if hit brake hard with road wet tires could slide just be easy drive normal

    Reply
    Flag This
  • Medium-star Best Answer
    December 02, 2010, 04:50
    Profile_thumbnail
     Master

    I'd definitely double check the clearance at the sensor, as Roy suggested. A little oxidation / rust at the mounting surface of the sensors can raise the sensor enough to lose signal.
    Here is a TSB for this problem:

    Brakes - Low Speed (Below 5 MPH) ABS Activation

    Bulletin No.: 02-05-25-006B

    Date: January 05, 2006

    TECHNICAL
    Subject:
    Antilock Brake (ABS) Activation At Low Speeds (Clean Wheel Speed Sensor Mounting Surface)

    Models:
    1999-2000 Cadillac Escalade
    1995-1999 Chevrolet Silverado (Old Style)
    1995-2000 Chevrolet Suburban, Tahoe (Old Style)
    1995-2003 Chevrolet Astro Van, Blazer, S10
    1995-1999 GMC Sierra (Old Style)
    1995-2000 GMC Yukon, Yukon XL (Old Style)
    1995-2001 GMC Envoy, Jimmy
    1995-2003 GMC Safari Van, Sonoma
    1995-2001 Oldsmobile Bravada

    Supercede:

    This bulletin is being revised to update the correction and warranty information. Please discard Corporate Bulletin Number 02-05-25-006A (Section 05 - Brakes).

    Condition

    Some customers may comment on ABS activation at low speeds, usually below 8 km/h (5 mph). Upon investigation, the technician will find no DTCs set.

    Cause

    The cause of this condition may be an increased air gap between the wheel speed sensor and the hub reluctor ring due to rust and debris built up on the sensor mounting surface.

    Correction

    Measure AC voltage and clean wheel speed sensor mounting surfaces.
    1. Raise the vehicle on a hoist.

    2. Disconnect both the front wheel speed sensor harness connectors.

    3. Place a DVM across the terminals of each sensor connector.

    4. Rotate the wheel with hand speed and measure the ACmV's. The reading should be at least 350 ACmV's.

    5. If the reading is between 200 and 350 ACmV's, remove the wheel, caliper and rotor in order to gain access to the speed sensor.

    6. Remove the wheel speed sensor and plug the hole to prevent debris from falling into the hub during service.

    7. Clean the wheel speed sensor mounting surface using a wire brush, sand paper, emery cloth, ScotchBrite(TM) or other suitable material. Be sure to thoroughly clean the wheel speed sensor surface. There should be no rust or corrosion.

    8. Check the sensor head to determine if it has been warped/distorted due to the corrosion build up or other causes. Check the mounting surface on the sensor head for flatness by placing it on the edge of a metal machinists scale or other suitable straight edge to measure the flatness. Check the sensor for flatness in multiple (minimum 3) positions/directions. If the sensor head is distorted, replace the sensor.

    9. Apply (spray) two thin coats of the specified rust penetrating lubricant (corrosion inhibitor) to the complete sensor mounting surface on the bearing hub. Allow to dry for 3-5 minutes between coats. Use ONLY Rust Penetrating Lubricant, P/N 89022217 (Canadian P/N 89022218).

    10. When the corrosion inhibitor is dry to the touch (about 10 minutes), apply a thin layer of bearing grease to the hub surface and sensor 0-ring prior to sensor installation. Use ONLY Wheel Bearing Lubricant, P/N 01051344 (Canadian P/N 993037).

    11. Install either the original sensor or a new one in the hub and secure the sensor. Ensure that the sensor is seated flush against the hub.

    12. Install the rotor, the caliper and the wheel.

    13. Place the DVM across the sensor terminals and recheck the voltage while rotating the wheel by hand. The voltage should now read at least 350 ACmV's.

    Zee

    Reply
    Flag This