a friend was helping install a new battery and he hooked it up backwards on 1997 Infiniti I30

he tried to start it but it didn't do any thing after discovering the problem we corrected it and tried to start it and it won't start now the car ran perfect prior to this we found the main fuse was blown and we checked all the fuseable links all were good still won't start fuel pumps working but found that it not getting fire any suggestions what else it would have hurt ? or what to test ?

by in Louisville, KY on March 13, 2013
1 answer 4 comments
ANSWER by on March 13, 2013
did you pre-charge the battery? try a jump start. if it works. take it for a spin to charge the battery sufficiently.
COMMENT by on March 17, 2013
what are talking about "did he pre-charge the battery" did you read what i said happened the battery was installed neg to pos pos to neg and the key was turned over to try and start it duhhhhhh up date scanned for codes got knock sensor and camshaft sensor cleared them and tried to start codes returned clered again camshaft retured checked cam sensor was good but replaced anyways tried nothing again and both codes returnedchecked fuel pressure is good have power to coils
COMMENT by on March 17, 2013
u say u try start and nothing. is not turning over at all? cliking sound? if so you may have fried ur starter.
COMMENT by on March 19, 2013
NO IT TURNS OVER BUT AFTER DOING SO TEST CAM SENSOR TEST GOOD BUT WIRING OR EEC FRIDE POSSIBLY
COMMENT by on March 19, 2013
have you inquired about whether or not reprogramming the computer would help? reverse charge may have thrown every thing off.