» » »

GMC Q&A

Ask Your Question

1995 GMC Suburban 1500 Question: 95 gmc suburban tranny probs . intermittently the abs light comes on speedo

 

Question

beachman, 5.7L V8, Harrisburg, MO, December 09, 2011, 15:58
 Rookie

driving the abs comes on then the speedo goes to 0 and it feels like I'm in neutral I slow down and have first gear and can sometimes get it to manually shift in to second go for third and get neutral?
no codes pop up any ideas?

1 Answer
Flag This
  • Answer #1

    ASE Master Tech from Cascade Autowerkes, December 09, 2011, 20:23
     Enthusiast

    The vehicle speed sensor and/or wiring is a good start.

    Flag This
  • Reply

    beachman, December 10, 2011, 08:32
     Rookie

    I swapped out the speed sensor and the wire appears to look in tack is there anyway to test the wire?
    Looking in my haynes book and it shows a speed sensor buffer which appears to connect with the speedo,abs,and tranny any possibility that could be the problem?

    Flag This
  • Reply

    ASE Master Tech, December 10, 2011, 13:41
     Enthusiast

    Basics first: make sure battery cables are completely clean and all vehicle ground connections are good and the alternator isn't acting up. Then check for related TSB's that may address this issue. Domestic vehicles often require computer recalibrations, but more so on newer models (1996 up with OBD2 diagnostics).
    A digital volt/ohm meter is needed and leads long enough to check from sensor to computer. Be sure to check all connectors; clean or replace as needed and sensure terminals have positive engagement.
    A shop with a lab scope can verify the speed sensor is outputting an acceptable wave form (at the computer) or possibly with a scanner (OEM/Dealer type). Also, not all sensors are created equal and may require using the dealer part.

    Reply
    Flag This