» » »

Chevrolet Q&A

Ask Your Question

1999 Chevrolet Blazer Question: 4wd not working

 

Question

Ben Miller, Cincinnati, OH, January 12, 2011, 11:32
 Rookie

4wd switch lights up, however, 4hi or 4lo will not engage. Sometimes I hear the encoder motor working, but, the shift to 4wd does not happen. Thank You.

2 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, January 12, 2011, 13:11
    Profile_thumbnail
     Master

    Is the service engine soon/check engine light on? If so some codes may be stored in the computer in your car. I am not very familiar with Blazers but you may find information and test procedures at Alldata. Autozone have some popular workshop manuals for free on line once you register (for free) on their website http://bit.ly/autozone_repair_info or there is a company that independent auto repair shops "buy" their information from that offer a very reasonable service to do it yourselvers. You can get a one week subscription or year subscription very cheap. The information is year make and model specific repair procedures, service bulletins, component locations, wiring diagrams ect.... great quality information same as the professionals have ,much better than generic workshop manuals from parts stores, much cheaper than the factory manual try http://bit.ly/mitchell_repair_manuals_online
    and get an online repair manual subscription.

    Reply
    Flag This
  • Medium-star Best Answer
    January 28, 2011, 15:19
     Rookie

    4x4 motor needs replaced not engaging when you push button the motor not turning all the way to engage.

    Flag This
  • Reply

    elcamino1971, February 22, 2011, 07:46
     Enthusiast

    I had the same problem in my 2003 S-10. Simple fix. Shop said that it is caused by NOT using the 4X. solution is to use it occasionaly throughout the year on short trips to ensure it still engages and works.

    Reply
    Flag This