300zx on 1990 Nissan 300ZX

I have a 1990 Nissan 300zx N/A which hasa proble when i start up in the morn ing the car runs good but after running for abot 10 to 20 minutes the car loses power what could be the problem?

by in Tulare, CA on February 12, 2009
1 answer 2 comments
ANSWER by on February 12, 2009
How many miles are on your car? I have seen the catalytic converter get restricted, I have seen air flow meter failure, and fuel delivery/ volume problems, but everything is a guess without actually having the car to run tests on. This car has diagnostic capabilities. A computer that has control over the ignition and fuel injection is located in the passenger foot well area and has several modes of diagnostics. Does the car just gradually loose power as you accelerate, or chug and sputter as you try to accelerate?
2 people like thisFlag inappropiate
COMMENT by on July 14, 2010
I'm having the same problem with mine. It's doing all that you're saying. I need help
COMMENT by on March 02, 2011
chugs and sputter as u try to accelerate
Related Items:
I HAVE A 1987 300ZX. LATELY THE CAR BUCKS AT SPEEDS UNDER 30 mph. I ADDED FUEL INJECTOR CLEANING FLUID, BUT NO LUCK.
My Z has been having acceleration problems as of late. I changed the fuel filter and it did no good. No check engine light has come up but I believe the bulb is out. After doing some research I bel...
I have a 1994 300zx non-turbo. Over the last 6 weeks, the vehicle has had an extended crank, when the engine is co...
I just got this 1990 Nissan 300zx It will not roll in reverse. I start it put it in reverse and it will not go. I even turned the...