» » »

Buick Q&A

Ask Your Question

2000 Buick LeSabre Question: 2000 buick lesabre test read po102 mass air flow sensor or vaf low input

 

Question

Durdie, Memphis, TN, August 27, 2012, 13:18
 Rookie

i hear a sucking sound for 30 sec or more when its cold it stops then i can drive off. when i stop at a light the RPMs raise up like im about to take off. sometimes it ideal down.

3 Answers
Flag This
  • Answer #1

    Chevy Power August 27, 2012, 14:02
     Journeyman

    It sounds like a bad mass air flow sensor. You can unplug it and drive it. If the idle issue clears up then you will need to replace the mass air flow sensor.

    Flag This
  • Reply

    Durdie, August 27, 2012, 21:22
     Rookie

    it still rides the same

    Reply
    Flag This
  • Answer #2

    pushrod August 27, 2012, 15:10
    Profile_thumbnail
     Master

    REPAIR VACUUM LEAK,INCLU. INTAKE TUBE. DID HAVE A LOT OF MAF TROUBLE
    WITH THIS CAR.

    Reply
    Flag This
  • Answer #3

    ziptie12 August 29, 2012, 04:15
     Master

    Just for curiosity sake...does the 'sucking sound ' happen when your're holding the brakes?

    Flag This
  • Reply

    Durdie, August 29, 2012, 23:25
     Rookie

    no. it just does it in the morning when i first crank up and when it sit for a while, and i crank up again only for the first 30 sec

    Flag This
  • Reply

    pushrod, August 30, 2012, 16:15
    Profile_thumbnail
     Master

    CHECK INTAKE TUBE CLOSELY FOR SPLIT OR HOLE, MAY NEED TO REMOVE
    FOR INSPECTION. IF YOU REMOVED THIS TUBE AND STARTED THE CAR, IT
    WOULD SOUND JUST LIKE YOU DESCRIBED. THAT'S THE REASON I SAY CHECK
    IT BEND IT LOOK ALL OVER IT. WHEN FIRST STARTED THE IAC IS OPENED UP MORE
    AS ENGINE RUNS A FEW SECONDS IAC CLOSES AND "SUCKING" SOUND SUBSIDES.
    ALSO CHECK FOR LOOSE AIR FILTER COVER.

    Reply
    Flag This