» » »

Ford Q&A

Ask Your Question

1998 Ford Expedition Question: 1998 expedition all turn signals inop

 

Question

tito1, 4.6L V8, San Bernardino, CA, August 20, 2009, 12:21
 Rookie

need help on locate problem all turn signals,emergency lights, and horn stop working all fuses OK. found turn signal relays seems to be working fine

2 Answers
Flag This
  • Medium-star Best Answer
    patrick mannion from Greg Solow's Engine Room, August 20, 2009, 22:22
    Profile_thumbnail
     Master

    Check fuse 1 (15 Amp) and fuse 23 (10 Amp) again. Flasher unit is next to the blower motor relay under the dash. The horn is protected by fuse 5 (20 amp). Quickest wat to test the horn switch and "clock spring" is ground the dark blue wire at the steering column if the horn blows the relay,horn wring and fuse is OK, problem may be the clock spring at the steering column. Test the horn itself for voltage when the horn switch is pressed.

    Flag This
  • Reply

    tito1, August 22, 2009, 14:05
     Rookie

    thank you for your response, i traced problem to bad turn signal relay and fuse #1 not making good contact and it was working intermittent. Repaired to work signals/flashers and yes, is a bad "clock spring" need replace. I noticed that the right rear turn signal is not working. light bulb is good. I'm tracing for broken connection. What color wires need to check from under the dash?. Again thanks for your help.

    Reply
    Flag This
  • Answer #2

    Visitor, November 28, 2010, 10:37

    damn that sucks

    Reply
    Flag This