115,000 miles on sorento cam sensor went out on 2003 Kia Sorento

when dealer went to repair they found the bolt for harmonic balancer was loose and had broken off inside because from what they said the same bolt was used when i had timing belt replaced at 64,000 instead of new bolt so it backed out. they got car running but they said it has a vibration when acceleration cannot find problem. I'm in a rental car and on vacation and starting to worry. Mark

by in Sebastian, FL on October 10, 2011
2 answers 3 comments
ANSWER by on October 10, 2011
did they replace the balancer?? if the bolt broke, then it may have damaged the balancer. Roy
COMMENT by on October 13, 2011
spoke to kia dealership and they have replaced cam sensor, crank sensor and harmonic balancer. It is running now with a slight vibration at idle. they recommend down the road new engine mounts ?? what do you think. They say car should be good to get back home from Orangeburg SC to Sebastian Fl.
COMMENT by on October 13, 2011
without feeling it I could not tell you with any certainty. I would get a second opinion. Roy
ANSWER by on October 10, 2011
Another possibility is the nose of the crankshaft could even be damaged. Is the harmonic balance a tight fit on the crank and the key tight and secure in the crank? Kia as a car manufacturer put a lot of great technical information and work shop manuals on line for free for Kia owners. www.kiatechinfo.com
COMMENT by on October 18, 2011
picked up car from dealer today crank sensor replaced , cam sensor replaced , damper balencer pulley replaced. car now starts and runs but leaps , vibration, loss of power , hard shifting will try to limp it bak to florida think it will be okay? kia t/l advised that crankshaft may need to be replaced ???? I s it worth it? Mark