» » »

Oldsmobile Q&A

Ask Your Question

2001 Oldsmobile Alero Question: 01 alero engine issues

 

Question

cd-ohio, 2.4L 4 Cylinder, Bolivar, OH, March 01, 2014, 13:18
 Rookie

I have an 01 alero 2.4l 4 cylinder that started acting up - while driving it seemed like it had a hesitation now and then but never stalled. Seen I just replaced plugs and boots a few months prior and changed the fuel filter. And that's when the issue began - after doing this I started the car and immediately it started to idle very rough and discharging light black smoke. I changed the plug, boots, map sensor,the fuel pump, and since the exhaust will need replaced anyway soon - I popped out the cat converter but nothing has changed in how its running. Also while checking things to see if intake manifold gasket has bad I find excess oil in the air hose/box - between filter and throttle body and that's where I stopped. Can anyone help me figure out the issue with this is and why there oil in this area.

1 Answer
Flag This
  • Answer #1

    GPOF March 01, 2014, 13:50
     Enthusiast

    Blowby., 1st check your PVC valve. Alot of people over look this valve. 2nd, with the engine hot and running, take the oil cap off. If smoke or air is flowing outward this is an indication of blowby which a leak down test should be done. 3rd, it could be worn piston rings.

    Flag This
  • Reply

    cd-ohio, March 01, 2014, 14:55
     Rookie

    Ok thank you. It doesnt have a pvc value but i will check other things you said.

    Reply
    Flag This